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Pay amount is not coming through to SelectPay pending changes correctly

Pending changes does not display the new pay rate for an employee when it was changed in HR.

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Written by Harry Ledger
Updated over 3 months ago

Scenario 1

A pay history record was created incorrectly in SelectHR with Pay Amount A and came through to pending changes in SelectPay. The pay amount has been corrected to Pay Amount B in SelectHR, but this has not come through to Pending Changes.

Cause

The Pending Changes hold two separate values from SelectHR for a pay history Record: Rate and New Rate. The New Rate acts as somewhat of an override to the Rate, so if the New Rate is present in the Pending Changes, updates to the Rate from SelectHR will be successful, but will not take effect due to the New Rate value.

Resolution

  1. Reject the record in SelectPay, and then delete the pending change entirely.

  2. Log in to SelectHR.

  3. Click Employees, Employees, Career History.

  4. Open the impacted employee record.

  5. Remove the Payroll Name from the employee's Appointment Record.

  6. Click Save.

  7. Add the Payroll Name back into the employee's Appointment Record.

  8. Click Save.

This will force a resubmission of the employee's entire record with the correct rate, which can then be processed from Pending Changes.


Scenario 2

If a pay history record is created using the Pay Frequency as Year (Annual), the change will not be sent to SelectPay.

Resolution

  1. Log in to SelectHR.

  2. Click Employees, Employees, Career History.

  3. Open the impacted employee record.

  4. Click on Basic Pay/Other Pay (Depending on where the Pay record is situated)

  5. Change the Pay Frequency to Monthly.

  6. Click Save.

This will trigger the record to be sent to SelectPay.

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